Question
When I tried to connect from HULFT Square to a destination system with Web Service API, it failed and HTTP error codes were recorded.
I would like to know possible causes and what can I do based on the error codes.
Answer
HTTP error codes might be displayed when connecting with REST API, Web Service API, etc.
Error codes are returned as HTTP responses from destination system to HULFT Square.
It might be possible to distinguish from the error code whether the problem is with the destination system or with the client settings.
Here we introduce two typical HTTP error codes.
500 Internal Server Error
[Cause]
This error code is returned when some problem occurs on the server side that processes requests from a client.
[Countermeasure]
In the case of a connection between HULFT Square and an external service, HULFT Square corresponds to the client.
Please check if there is a problem with the destination server.
If the above does not resolve the problem, please contact HULFT Square Technical Support Center.
401 Unauthorized
[Cause]
This error code is generally returned when a client request to a server fails to authenticate.
[Countermeasure]
Please check if the authentication information set in logic icons and connection resource settings are correct.
Please refer to the following manuals about authentication with each REST operation.
Execute GET
https://www.hulft.com/help/en-us/HULFTSquare/Content/Designer/Connector/rest_execute_http_get.htm
Execute POST
https://www.hulft.com/help/en-us/HULFTSquare/Content/Designer/Connector/rest_execute_http_post.htm
Execute PUT
https://www.hulft.com/help/en-us/HULFTSquare/Content/Designer/Connector/rest_execute_http_put.htm
Execute DELETE
https://www.hulft.com/help/en-us/HULFTSquare/Content/Designer/Connector/rest_execute_http_delete.htm
Comments
0 comments
Article is closed for comments.